Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  jeansilva em Dom 26 Maio - 18:17

Olá amigos, tenho o meu sistema com o Thunder Cache e Mk-Auth, porem, desde a implantação do thunder que minhas regras de corte, aviso e manutenção deixaram de funcionar. A de corte, no Mangle e Nat aparecem habilitadas, mas o clientes continuam navegando. Já a Pagina de manutenção, que coloquei no NAT, ao ser habilitada, corta geral, ou seja, ninguém mais navega.

Eis as regras que estão no momento em meu sistema:

NAT
Código:
/ip firewall nat
add action=dst-nat chain=pre-hotspot comment="====== redirecionamento pag. corte\
    \_mk-auth Mangle.===========================================================\
    ====" disabled=no hotspot=auth packet-mark=bloqueado protocol=tcp \
    to-addresses=172.31.255.2 to-ports=85

add action=dst-nat chain=dstnat comment="PG AVISO" connection-limit=!1,32 \
    disabled=no dst-port=0-65535 protocol=tcp src-address-list=pgaviso \
    to-addresses=172.31.255.2 to-ports=88
add action=dst-nat chain=dstnat comment="AVISO DE MANUTEN\C7\C3O" disabled=yes \
    dst-port=80 in-interface=bridge1 protocol=tcp src-address=0.0.0.0/0 \
    to-addresses=172.31.255.2 to-ports=89

MANGLE
Código:
/ip firewall mangle
add action=jump chain=prerouting comment="=========== redirecionamento pag. cort\
    e mk-auth Mangle.================================================\
    ============================\
    ===========" disabled=no hotspot="" jump-target=hotspot

Adicionais: As regras uso acima das demais e autenticação é via hotspot.
Obrigado quem puder ajudar!


Última edição por jeansilva em Seg 27 Maio - 2:40, editado 1 vez(es)
avatar
jeansilva
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 41
Pontos : 1967
Reputação : 200
Data de inscrição : 12/02/2013
Idade : 39
Localização : Amazonas

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  Marco em Dom 26 Maio - 18:37

A ordem das regras é importante. O desvio para o cache deve sempre estar depois das regras de controle.

Marco
Especialista
Especialista

Mensagens : 364
Pontos : 2705
Reputação : 600
Data de inscrição : 12/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  jeansilva em Dom 26 Maio - 18:46

Marco escreveu:A ordem das regras é importante. O desvio para o cache deve sempre estar depois das regras de controle.


Marco, as regras de controle estão acima.
avatar
jeansilva
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 41
Pontos : 1967
Reputação : 200
Data de inscrição : 12/02/2013
Idade : 39
Localização : Amazonas

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  Marco em Dom 26 Maio - 20:28

jeansilva escreveu:Marco, as regras de controle estão acima.

E as regras de desvio para o cache?

Marco
Especialista
Especialista

Mensagens : 364
Pontos : 2705
Reputação : 600
Data de inscrição : 12/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  jeansilva em Dom 26 Maio - 21:40

Marco escreveu:
jeansilva escreveu:Marco, as regras de controle estão acima.

E as regras de desvio para o cache?

Estão logo abaixo dessas aí que postei.
avatar
jeansilva
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 41
Pontos : 1967
Reputação : 200
Data de inscrição : 12/02/2013
Idade : 39
Localização : Amazonas

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  Marco em Dom 26 Maio - 23:26

jeansilva escreveu:Estão logo abaixo dessas aí que postei.

Em qual linha?

Use o botão CODE na barra de formatação. Ajuda a ler o código melhor.

Marco
Especialista
Especialista

Mensagens : 364
Pontos : 2705
Reputação : 600
Data de inscrição : 12/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  jeansilva em Seg 27 Maio - 9:34

Marco, as regras do 1º post, são somente as regras de direcionamento pra pagina de corte, aviso e manutenção, respectivamente. As regras de redirecionamento do Thunder aqui no meu concentrador, estão logo abaixo dessas regras aí. Pelo que li nos fóruns, essas regras das paginas são colocadas acima dos redirecionamentos do cache. O problema é que bloqueio um cliente, mas ele continua navegando.
avatar
jeansilva
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 41
Pontos : 1967
Reputação : 200
Data de inscrição : 12/02/2013
Idade : 39
Localização : Amazonas

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  mjr88 em Ter 28 Maio - 11:12

jeansilva escreveu:Marco, as regras do 1º post, são somente as regras de
direcionamento pra pagina de corte, aviso e manutenção,
respectivamente. As regras de redirecionamento do Thunder aqui no meu
concentrador, estão logo abaixo dessas regras aí. Pelo que li nos
fóruns, essas regras das paginas são colocadas acima dos
redirecionamentos do cache. O problema é que bloqueio um cliente, mas
ele continua navegando.

Aceita os clientes bloqueados/com aviso no Mangle antes de ir pro Thunder. Só cole as regras no terminal do MK:

Código:
/ip firewall mangle add place-before=0 chain=prerouting src-address-list=pgaviso action=accept
/ip firewall mangle add place-before=0 chain=prerouting src-address-list=pgcorte action=accept

_________________
Mário Jr.
ThunderCache 7.1 Developer | mario@bmsoftware.org

mjr88
MODERADOR
MODERADOR

Mensagens : 49
Pontos : 1786
Reputação : 0
Data de inscrição : 16/01/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  jeansilva em Dom 16 Jun - 14:10

Mário a regra funcionou perfeito colocando-a acima da regra de redirecionamento do Thunder e abaixo da Regra de Redirecionamento da Pag de Corte. Mas com um porém: Só se cadastrar manual em /ip address list o ip do cliente bloqueado. Não teria uma forma de o cliente ser bloqueado e o ip dele automaticamente ja ser inserido no address list?

avatar
jeansilva
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 41
Pontos : 1967
Reputação : 200
Data de inscrição : 12/02/2013
Idade : 39
Localização : Amazonas

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  Marco em Dom 16 Jun - 14:27

jeansilva escreveu:Mário a regra funcionou perfeito colocando-a acima da regra de redirecionamento do Thunder e abaixo da Regra de Redirecionamento da Pag de Corte. Mas com um porém: Só se cadastrar manual em /ip address list o ip do cliente bloqueado. Não teria uma forma de o cliente ser bloqueado e o ip dele automaticamente ja ser inserido no address list?

O Mk-AUTH usa esse mecanismo via SSH.

Marco
Especialista
Especialista

Mensagens : 364
Pontos : 2705
Reputação : 600
Data de inscrição : 12/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  jeansilva em Dom 16 Jun - 14:33

Marco escreveu:
jeansilva escreveu:Mário a regra funcionou perfeito colocando-a acima da regra de redirecionamento do Thunder e abaixo da Regra de Redirecionamento da Pag de Corte. Mas com um porém: Só se cadastrar manual em /ip address list o ip do cliente bloqueado. Não teria uma forma de o cliente ser bloqueado e o ip dele automaticamente ja ser inserido no address list?

O Mk-AUTH usa esse mecanismo via SSH.
Marco, nesse caso devo mudar então o corte de mangle para SSH?
avatar
jeansilva
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 41
Pontos : 1967
Reputação : 200
Data de inscrição : 12/02/2013
Idade : 39
Localização : Amazonas

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  Marco em Dom 16 Jun - 14:44

jeansilva escreveu:Marco, nesse caso devo mudar então o corte de mangle para SSH?

O MK-AUTH coloca os IPs dos clientes bloqueados numa address list chamada `pgcorte'.

Marco
Especialista
Especialista

Mensagens : 364
Pontos : 2705
Reputação : 600
Data de inscrição : 12/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  jeansilva em Dom 16 Jun - 16:23

Marco escreveu:
jeansilva escreveu:Marco, nesse caso devo mudar então o corte de mangle para SSH?

O MK-AUTH coloca os IPs dos clientes bloqueados numa address list chamada `pgcorte'.

Mas qual a forma de corte configurada dentro do teu MK-AUTH? Mangle (x) ou SSH (x)?
avatar
jeansilva
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 41
Pontos : 1967
Reputação : 200
Data de inscrição : 12/02/2013
Idade : 39
Localização : Amazonas

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  Marco em Dom 16 Jun - 16:59

jeansilva escreveu:Mas qual a forma de corte configurada dentro do teu MK-AUTH? Mangle (x) ou SSH (x)?

Em NAT:
Código:
;;; PG CORTE
chain=dstnat action=dst-nat to-addresses=187.nnn.nnn.nnn to-ports=85 protocol=tcp dst-address=!187.nnn.nnn.nnn src-address-list=pgcorte

É necessário habilitar o SSH no Mikrotik para que o MK-AUTH coloque os clientes bloqueados na lista `pgcorte'. O MK-AUTH deve ser configurado de acordo também.

Marco
Especialista
Especialista

Mensagens : 364
Pontos : 2705
Reputação : 600
Data de inscrição : 12/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Firewall: Pagina de Corte, de Aviso e de Manutenção deixaram de funcionar.

Mensagem  Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum