Como entregar IP Valido ao Cliente através do mk-auth

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Como entregar IP Valido ao Cliente através do mk-auth

Mensagem  rbotelecom em Qua 21 Maio - 21:23

Boa Noite Lista.

Seguinte to com um /26 aqui e gostaria de entregar ip valido a alguns clientes fixo e os ips que sobrarem entregar o ip em rotação ou seja dinâmico.

Minha ideia seria cada classe poll poderia responder por um ip valido, assim eu poderia selecionar que cada cliente que conectasse no painel X tivesse o poll X e ip valido X

Exemplo:

Painel 1 Poll 10.2.0.1/26 ip publico 201.xx.xx.195
Painel 2 Poll 10.2.1.1/26 ip publico 201.xx.xx.196
Painel 3 Poll 10.2.2.1/26 ip publico 201.xx.xx.197
Painel 4 Poll 10.2.3.1/26 ip publico 201.xx.xx.198

E assim sucessivamente, pois se tivesse algum problema com federal ficaria mais facil olhar de onde partiu os ips.

No caso minha estrutura é OPERADORA A E B ----> BALANCE---> CONCENTRADOR -------> AP---> Clientes

Sendo que na Operadora A tenho um /26 ja na B apenas 1 ip Fixo.

Como fazer para entregar os ips públicos no concentrador sendo que o concentrador recebe o link balanceado.

Não tenho experiencia com ip publico e não consegui fazer funcionar. Alguem poderia dar uma força?

Obrigado, Flávio.

rbotelecom
Iniciante
Iniciante

Mensagens : 8
Pontos : 1398
Reputação : 0
Data de inscrição : 18/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Como entregar IP Valido ao Cliente através do mk-auth

Mensagem  Renato em Qua 21 Maio - 21:37

Fica complicado entregar ips validos para seu cliente usando balance com 02 operadoras.
A forma correta seria vc ter ASN e subir BGP pelas duas operadoras.

Renato
MODERADOR
MODERADOR

Mensagens : 93
Pontos : 1724
Reputação : 203
Data de inscrição : 19/01/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Como entregar IP Valido ao Cliente através do mk-auth

Mensagem  rbotelecom em Qua 21 Maio - 21:47

Renato escreveu:Fica complicado entregar ips validos para seu cliente usando balance com 02 operadoras.
A forma correta seria vc ter ASN e subir BGP pelas duas operadoras.

Sim eu sei mas a operadora 2 é adsl, ai ja viu ne.
Por enquanto nao tenho como conseguir uma segunda operadora, o custo inviabiliza.
Sei que tem jeito de fazer so ainda não sei como.

Material que eu estava vendo mas nao consegui resolver.
Segue
*****************//////////////////////////////***************************

X Links ---->> Balance ------>>>> Concentrador

No NAT do Link onde tenho os IPs válidos faço uma exceção para o bloco de ips válidos, crio uma address list com esses ips válidos, adiciono uma regra de markrouting especifica para o gateway de saída dos ips válidos, observando a ordem dessa regra que deve estar a cima das demais regras de markrouting.

add action=mark-routing chain=prerouting comment=\
"Marcadores de Rota - Excecao IPs Validos" in-interface=clientes \
new-routing-mark=to_wlan1 passthrough=no src-address-list="Rota IPs Validos"

**************//////////////////////*****************************

/ip firewall nat
add action=masquerade chain=srcnat comment=SERVIDOR dst-address=\
out-interface=ether1 src-address=!189.126.x.x/27
add action=masquerade chain=srcnat comment=SERVIDOR out-interface=\
"Gvt - Invalido"
add action=masquerade chain=srcnat comment=SERVIDOR out-interface=\
"Gvt - Valido"

*********************////////////////////////////////************************

Mangle


/ip firewall mangle
add chain=prerouting comment=Loopback dst-address-list=loopback in-interface=\
clientes
add action=mark-connection chain=input comment=wlan1_conn in-interface=ether1 \
new-connection-mark=wlan1_conn
add action=mark-connection chain=input comment=wlan2_conn in-interface=\
"Gvt - Invalido" new-connection-mark=wlan2_conn
add action=mark-connection chain=input comment=wlan2_conn in-interface=\
"Gvt - Valido" new-connection-mark=wlan3_conn
add action=mark-connection chain=output comment=to_wlan1 connection-mark=\
wlan1_conn new-connection-mark=to_wlan1 passthrough=no
add action=mark-connection chain=output comment=to_wlan2 connection-mark=\
wlan2_conn new-connection-mark=to_wlan2 passthrough=no
add action=mark-connection chain=output comment=to_wlan3 connection-mark=\
wlan3_conn new-connection-mark=to_wlan3 passthrough=no
add action=mark-connection chain=prerouting comment=Contadores \
connection-state=new dst-address-type=!local in-interface=clientes \
new-connection-mark=wlan1_conn per-connection-classifier=\
both-addresses:3/0
add action=mark-connection chain=prerouting connection-state=new \
dst-address-type=!local in-interface=clientes new-connection-mark=\
wlan2_conn per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=prerouting connection-state=new \
dst-address-type=!local in-interface=clientes new-connection-mark=\
wlan3_conn per-connection-classifier=both-addresses:3/2
add action=mark-routing chain=prerouting comment=\
"Marcadores de Rota - Excecao IPs Validos" in-interface=clientes \
new-routing-mark=to_wlan1 passthrough=no src-address-list="Rota IP VALIDO"
add action=mark-routing chain=prerouting comment=\
"Marcadores de Rota - Rota GVT" in-interface=clientes new-routing-mark=\
to_wlan2 passthrough=no src-address-list="Rota GVT"
add action=mark-routing chain=prerouting comment="Marcadores de Rota " \
connection-mark=wlan1_conn in-interface=clientes new-routing-mark=to_wlan1 \
passthrough=no
add action=mark-routing chain=prerouting connection-mark=wlan2_conn \
in-interface=clientes new-routing-mark=to_wlan2 passthrough=no
add action=mark-routing chain=prerouting connection-mark=wlan3_conn \
in-interface=clientes new-routing-mark=to_wlan3 passthrough=no


ip firewall address-list


/ip firewall address-list
add address=10.200.1.2 comment="Clientes que deverao sair pela gvt - para adici\
onar novo apenas copie a regra e coloque o ip desejado" list="Rota GVT"
add address=189.126.x.x/27 comment=\
"Clientes que deverao sair pelo Dedicado" list="Rota IP Valido"
add address=127.0.0.1 list=loopback
add address=123.123.123.2 list=liberados
add address=192.168.2.124 list=liberados
add address=170.66.11.0/24 list=loopback




ip route


/ip route
add distance=1 gateway=189.126.xx.y routing-mark=to_wlan1
add distance=1 gateway="Gvt - Invalido" routing-mark=to_wlan2
add distance=1 gateway="Gvt - Valido" routing-mark=to_wlan3
add distance=1 gateway=189.126.xx.yy
add distance=2 gateway="Gvt - Valido"
add distance=3 gateway="Gvt - Invalido"
add comment="Rota IPs Validos" distance=1 dst-address=189.126.99.yy/27 \
gateway=10.200.1.1

Nota: 189.126.99.yy/27 Bloco de IPs válidos.
10.200.1.1 IP do Concentrador que distribui os ips para os clientes.



rbotelecom
Iniciante
Iniciante

Mensagens : 8
Pontos : 1398
Reputação : 0
Data de inscrição : 18/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Como entregar IP Valido ao Cliente através do mk-auth

Mensagem  Conteúdo patrocinado Hoje à(s) 11:38


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum