Como usar dois servidores mikrotik no mesmo cache ?

Ir em baixo

Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  agt em Qua 20 Mar - 22:48

Oi amigos do forúm gostaria de uma ajuda de vcs tenho um servidor de cache e uso uma rb1100x2 neste servidor mais gostaria de ligar mais uma rb1100x2 no mesmo servidor de cache como devo proceder?

lembrando tenho um link dedicado é "4 dsl no load balance" o link dedicado não faz parte do balance ele passa por fora?

recebo o link edicado em uma rb1100x2 uso uma classe de ip?
recebo o dls na outra rb1100x2 uso outra classe de ip diferente?

tudo na mesma rede.

ai vem a questão como proceder para os dois servidores buscar do mesmo cache????

agt
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 20
Pontos : 2198
Reputação : 0
Data de inscrição : 08/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  Marcio Marques em Qua 20 Mar - 23:48

O seu servidor cache está em paralelo com sua RB ? diga como está sua topologia brother ,se possível desenhe por favor , assim fica mais fácil .

Abraço !

_________________
Analista de Sistemas e Consultoria para Provedores de Internet
avatar
Marcio Marques
ADMINISTRADOR FUNDADOR
ADMINISTRADOR FUNDADOR

Mensagens : 1226
Pontos : 105125
Reputação : 3215
Data de inscrição : 02/02/2012
Idade : 47
Localização : Belo Horizonte

Ver perfil do usuário http://marquescsh.blogspot.com

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  luiz biazus em Qui 21 Mar - 13:41

usa tproxy e roteia os ip's normalmente :-)
avatar
luiz biazus
MODERADOR
MODERADOR

Mensagens : 43
Pontos : 2248
Reputação : 1
Data de inscrição : 10/01/2013
Idade : 35
Localização : Passo Fundo - RS

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  agt em Sex 22 Mar - 0:30

Vo explicar com detalhe,

dois link um e "dedicado" outro "dsl"

roteadores diferente um pro dedicado e um load balance pro "dls"

saindo da estação inicial >via bullet até o provedor os dois link,

no provedor resebo o dedicado nunha rb 1100x2 com ip 192.168.x.x

o outro "dsl" na outra rb 1100x2 com ip 172.255.x.x

o cache so funciona com o link dedicado com uma rb 1100x2 em paralelo com a rb1100x2

agora como faço para colocar a RB do "DSL" para pegar do mesmo cache??

agt
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 20
Pontos : 2198
Reputação : 0
Data de inscrição : 08/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  demattos em Sex 22 Mar - 7:04

agt escreveu:Vo explicar com detalhe,

dois link um e "dedicado" outro "dsl"

roteadores diferente um pro dedicado e um load balance pro "dls"

saindo da estação inicial >via bullet até o provedor os dois link,

no provedor resebo o dedicado nunha rb 1100x2 com ip 192.168.x.x

o outro "dsl" na outra rb 1100x2 com ip 172.255.x.x

o cache so funciona com o link dedicado com uma rb 1100x2 em paralelo com a rb1100x2

agora como faso para colocar a RB do "DSL" para pegar do mesmo cache??

Os dois links vem pelo mesmo ptp e isto? caso afirmativo usa o tproxy com o cache em bridge passando a rede nele primeiro para depois ir para as rbs.

_________________
Rodrigo Rodrigues de Mattos
Téc. em Eletronica
Usuario Linux e mikrotik
avatar
demattos
MODERADOR
MODERADOR

Mensagens : 674
Pontos : 103874
Reputação : 1609
Data de inscrição : 02/02/2012
Idade : 41
Localização : criciuma / SC

Ver perfil do usuário http://www.criciumanet.com.br

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  Marcio Marques em Sex 22 Mar - 7:36

Como explicado assim amigo é assim que deve fazer :

MODENS ====> TPROXY EM BRIDGE====> SIWCTH ====>RBS====> CLIENTES


Vlw !

_________________
Analista de Sistemas e Consultoria para Provedores de Internet
avatar
Marcio Marques
ADMINISTRADOR FUNDADOR
ADMINISTRADOR FUNDADOR

Mensagens : 1226
Pontos : 105125
Reputação : 3215
Data de inscrição : 02/02/2012
Idade : 47
Localização : Belo Horizonte

Ver perfil do usuário http://marquescsh.blogspot.com

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  agt em Sex 22 Mar - 9:12

mais veja amigo tenho duas faixas de ip diferentes , uma pro ip dedicado e outra pro ip dsl então no cache coloco o ip dedicado no modo bridge e aponto um mikrotik pra quele ip e o ip do dsl como fica que e um ip diferente do dedicado?

agt
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 20
Pontos : 2198
Reputação : 0
Data de inscrição : 08/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  luiz biazus em Sex 22 Mar - 17:38

instalação modo bridge tproxy:

http://thundercache.es/recursos/bridge/modo-bridge/

avatar
luiz biazus
MODERADOR
MODERADOR

Mensagens : 43
Pontos : 2248
Reputação : 1
Data de inscrição : 10/01/2013
Idade : 35
Localização : Passo Fundo - RS

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  agt em Sex 22 Mar - 21:46

To entendendo como funciona,
então como tenho 2 ip diferente um dsl e um dedicado vindo na mesma rede ai na brigde do servidor coloco exemplo> entrada da rede ""ip DSL 192.168.x.x"" na mesma bridge ip DEDICADO> 172.255.x.x
"""Na lan saida"""" ai aponto os dois mikrotik cada um pra seu ip-
dedicado aponto 172.255.x.x
dsl aponto 192.168.x.x
isso pessoal????

agt
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 20
Pontos : 2198
Reputação : 0
Data de inscrição : 08/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  agt em Sex 22 Mar - 23:03

como tenho dois ip um dedicado outro dsl devo criar na bridge os dois ip e apontar os mikrotik para cada ip?

agt
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 20
Pontos : 2198
Reputação : 0
Data de inscrição : 08/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  demattos em Sab 23 Mar - 8:00

agt escreveu:como tenho dois ip um dedicado outro dsl devo criar na bridge os dois ip e apontar os mikrotik para cada ip?

Amigo vc tem q entender uma coisa para ficar claro para vc, bridge trabalha na camada de elase ou seja na camado 2 em miudos e totalmente transparente vc coloca ip nele só para gerência , pode ser ate um ip publico ou privado que vc tenha acesso para gerencia do cache somente isto, resulmindo ele e totalmente transparente para a rede. vc pode entrar com o cabo que vem do seu ptp e sair pela outra interface e ligar nas rb que sera como se o cache fose transparente. Em poucas palavras seria isto

abraco

_________________
Rodrigo Rodrigues de Mattos
Téc. em Eletronica
Usuario Linux e mikrotik
avatar
demattos
MODERADOR
MODERADOR

Mensagens : 674
Pontos : 103874
Reputação : 1609
Data de inscrição : 02/02/2012
Idade : 41
Localização : criciuma / SC

Ver perfil do usuário http://www.criciumanet.com.br

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  agt em Sab 23 Mar - 8:49

vou implantar depois posto o resultado para os amigos aqui do fórum .

agt
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 20
Pontos : 2198
Reputação : 0
Data de inscrição : 08/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  agt em Qua 27 Mar - 23:18

pessoal tô perdido no negócio tenho que pedir ajuda é o jeito.
veja , coloco o servidor de cache em modo bridge certo, aí coloco um ip para que tenho acesso a ele certo , mais aí tenho que apontar o mikrotik para este servidor de cache , aí pode até falar que não precisa mais como o cliente busca do cache sem endereçamento
ajudem sô leigo no negócio?

agt
Colaborador Iniciante
Colaborador Iniciante

Mensagens : 20
Pontos : 2198
Reputação : 0
Data de inscrição : 08/02/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  demattos em Qui 28 Mar - 10:33

agt escreveu:pessoal tô perdido no negócio tenho que pedir ajuda é o jeito.
veja , coloco o servidor de cache em modo bridge certo, aí coloco um ip para que tenho acesso a ele certo , mais aí tenho que apontar o mikrotik para este servidor de cache , aí pode até falar que não precisa mais como o cliente busca do cache sem endereçamento
ajudem sô leigo no negócio?

Bom dia, vamos la então.

Agora veremos como está nossa rede de testes, nossa topologia antes do Servidor Proxy em Bridge:





Nessa
rede acima cada cliente sai com seu IP público e se
colocássemos um Proxy Transparente mesmo que em Bridge,
teríamos o problema do IP que sairia para
navegação, que seria o do Proxy. Bom o objetivo
aqui é mostrar como configurar um Proxy 100% transparente e
em bridge usando o TProxy no kernel, iptables, ebtables e Squid, que no seu caso vc pode usar o thundercache que ja tem tudo configuraco para funciona nesta configuracao. Agora
vejamos como ficará nossa nova topologia. Reparem que o
gateway continua sendo o mesmo 186.193.x.1, porque o Proxy, para a
rede, não existirá:





Você pode perceber que o Tproxy e um função adicionada ao kernel do linux que faz as requisições de forma transparente, se você colocar seus links depois dele e criar dois gateway diferentes apos o cache com Tproxy ele continua fazendo o serviço de cache mas e proxy de forma transparente.





Duvidas post aí

_________________
Rodrigo Rodrigues de Mattos
Téc. em Eletronica
Usuario Linux e mikrotik
avatar
demattos
MODERADOR
MODERADOR

Mensagens : 674
Pontos : 103874
Reputação : 1609
Data de inscrição : 02/02/2012
Idade : 41
Localização : criciuma / SC

Ver perfil do usuário http://www.criciumanet.com.br

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  mjr88 em Dom 31 Mar - 10:59

Pessoal, infelizmente não vai funcionar assim.

Embora a bridge seja transparente, quando o trafego passa por ela e é redirecionado ao Thunder, o pacote perde o gateway de destino e o Thunder sempre envia pro Gateway padrão dele.

Vou dar uma ideia pra ficar mais fácil (sem bridge):

Links --- PTP ----- RB com roteamento dos Links ------ Switch ------- Thunder e MKs.

A RB de roteamento pode ser uma 750 ou qualquer outra com 3 ethers.

Ligações:

RB roteamento - ether1: Recebe Link Dedicado.
RB roteamento - ether2: Recebe ADSLs.
RB roteamento - ether3: Ligada no Switch.

Thunder (uma placa só): Ligada no Switch.

MK 1 e MK 2: Ligados no Switch.

Vou usar alguns IPs fictícios pra facilitar:

RB ether1 (Dedicado): 200.200.200.2/28
RB ether2 (ADSLs): 10.1.1.2/24
RB ether3 (Switch): 192.168.0.254/24

Thunder: 192.168.0.10/24 Gateway 192.168.0.254
MK1: 192.168.0.1/24 Gateway 192.168.0.254
MK2: 192.168.0.2/24 Gateway 192.168.0.254

Na RB, vc vai criar 5 rotas:

Rota padrão, destino 0.0.0.0/0 gateway 200.200.200.1 distance 1 sem routing-mark
Rota backup, destino 0.0.0.0/0 gateway 10.1.1.1 distance 2 sem routing-mark
Rota Dedicado, destino 0.0.0.0/0 gateway 200.200.200.1 distance 1 routing-mark rota_dedicado
Rota ADSLs, destino 0.0.0.0/0 gateway 10.1.1.1 distance 1 routing-mark rota_adsls
Rota Thunder, destino 0.0.0.0/0 gateway 192.168.0.10 distance 1 routing-mark rota_thunder

No MK1 e MK2 vc cria a rota_thunder também, como acima, e faz o redirecionamento normalmente:

/ip firewall mangle add chain=prerouting src-address= protocol=tcp dst-port=80 dst-address-list=!NO_CACHE action=mark-routing new-routing-mark=rota_thunder

No Thunder, em Configurações -> Configuração IP -> Firewall você vai adicionar a faixa 192.168.0.0/24 com o Repasse de IPs (TProxy) ativo. Vai também em Configurações -> ThunderCache -> Configurações Gerais, e escolhe um TOS qualquer em Marcação de Requisições à Internet. Vou supor que você escolha o TOS 112 (DSCP 28).

Na RB do roteamento, vc vai usar as regras:

/ip firewall mangle add chain=prerouting in-interface=ether3 protocol=tcp dst-port=80 dscp=28 action=mark-connection new-connection-mark=thunderout passthrough=yes comment="Marca Saida do Thunder"
/ip firewall mangle add chain=prerouting in-interface=!ether3 protocol=tcp src-port=80 connection-mark=thunderout action=mark-routing new-routing-mark=rota_thunder passthrough=no comment="Devolve Conexoes do Thunder"
/ip firewall mangle add chain=prerouting in-interface=ether3 src-address=192.168.0.1 dst-address-type=!local action=mark-routing new-routing-mark=rota_dedicado passthrough=no comment="192.168.0.1 Usa link dedicado"
/ip firewall mangle add chain=prerouting in-interface=ether3
src-address=192.168.0.2 dst-address-type=!local action=mark-routing
new-routing-mark=rota_adsls passthrough=no comment="192.168.0.2 Usa
links ADSL"

É isso, deve funcionar belezinha. O Cache full será feito nas RBs 1100, normalmente.

Qualquer dúvida posta aí.

Abraços.

edit: Não copie e cole as regras, pois eu fiz manual agora, não sei se estão corretas. Vai olhando elas e fazendo manualmente no WinBox.

_________________
Mário Jr.
ThunderCache 7.1 Developer | mario@bmsoftware.org

mjr88
MODERADOR
MODERADOR

Mensagens : 49
Pontos : 2243
Reputação : 0
Data de inscrição : 16/01/2013

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Como usar dois servidores mikrotik no mesmo cache ?

Mensagem  Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum