Queue Simple e Queue Tree do Mikrotik

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Queue Simple e Queue Tree do Mikrotik

Mensagem  lucas76 em Sex 16 Maio - 12:30

Olá  camaradas do fórum  só novato  aqui  e estou com dificuldade em limitar a velocidade de acesso dos clientes junto com o cache com o  QUEUE SIMPLE  e QUEUE TREE DO MIKROTIK.
Eu gostaria que o cliente acessa-se a internet com uma velocidade e o material que já foi para o cache acessa-se com outra velocidade.
Aqui eu tenho  2 servidores um BRASILFW 3.X  : Fazendo load  balace com 2 link ADSL velox de 10 mega em modo pppoe , cache em um hd secundário e DHCP desativado. O BRASILFW tá ok tendo Internet e fazendo o cache .
O meu problema é com o MIKROTIK   : Quando ativo o queue simples o cache não funciona quando desligo o queue simples o cache volta o funcionar só que na velocidade de 1m e não em 2m que esta nas regras do QUEUE  abaixo . configurei o MIKROTIK da seguite forma:
Só não utilizei as regras que usa a mesma placa de rede para cache e acesso a net .
Pois no BRASILFW  tenho duas placas de rede.
Amigos do fórum  já estou a 3 dias e não resolvir se poderem me ajudar já agradeço  pois so esta faltando o controle de banda dos clientes para terminar as configurações
 
Se quer usar ele em paralelo mesmo, segue tutorial disponibilizado a cima, mas se quer usar o bfw fazendo loud-balance e entregando o cache ao mesmo tempo pela mesma placa de rede que é o que indico para quem precisa fazer LB confiável e não tem RB para isto ou um mikrotik com tantas placas de redes disponíveis, segue o tutorial que deixo.

Faça instalação limpa do BrazilFW para garantir que não restará sobras de configurações antigas.

Configure seu BrazilFW para receber os links Internet seguindo os passos descritos na guia Load balance wiki .
Faça as devidas configurações para criar rotas direto no BrazilFW para acesso a bancos e outros que requerem sainda por um unico IP de forma que não precise alterar em nada no Mikrotik e assim mante-lo desafogando de regras para elevar o processamento e uso de memoria, faça rotas no BFW como na guia Rotas wiki.

Para melhor intendimento, renomeie suas placas de rede para... Considere a tabela abaixo no Mikrotik:
ether1: Saída para a Internet, terá o nome de Internet
ether2: Saída para os clientes. Terá o nome de Clientes

Configurando as interfaces no Mikrotik:

Agora daremos IP’s pelo terminal usando o Winbox clicando em ( IP + address ) para as devidas interfaces renomeadas.
5.0.0.1/20 interface= Clientes
192.168.0.2/24 interface= Internet

OBS: As ranges ip address descritas a cima é mera ilustração e podem ser alteradas para as que melhor lhes convier.

Para a interface Internet, é preciso configurar o links da seguinte forma.
Pelo Winbox entre na aba IP + Routes e clique no ( + ) e em Gateway adicione o IP do BrazilFW ( 192.168.0.1 ) clique no OK e estará criado o router para que o Mikrotik receba Internet dos links que o BrazilFW faz load balance.
Faltando apenas para navegar, ir pelo Winbox na aba ( IP + DNS ) e adicionas os DNS's da seguinte forma:
No primeiro DNS Servers, coloque: ( 5.0.0.1 ) e no segundo ( 192.168.0.1 ) clique em OK e teste sua internet para saber se funcionou.
Funcionando, é só seguir os passos, não funcionando, reveja onde pode ter errado e refaça, não esquecendo que o primeiro dns deve ser o de sua rede... a dica é, não faça remendos, sempre recomeçar do zero para que não deixe falhas e aprenda pela persistência.

Para ficar mais organizado, renomeie também seu Mikrotik para ( O NOME DE SUA RDE ) ou outro nome qualquer de modo que tenha melhor visão de onde tá mexendo.

Se for usar HOTSPOT, agora será a hora de cria-lo, se não usar, pule essa parte.

HOTSPOT:

Como no mikrotik já existe um hotspot default, não iremos criar outro e sim refazer o já existente.
Clique em ( IP + HOTSPOT ) na aba ( server profiles ) clique sobre o Hotspot já existente e preencha os campos como segue:

No campo Name: ( default )
No campo DNS Name: ( coloque um nome para ser visto como o dns na barra do navegador ) Exemplo: ( hotspot.login )
No campo HTML Directory: ( hotspot )
No Campo HTTP Proxy Port: ( 0 )

Na aba Login marque o ( HTTP CHAP e Cookie )
E no campo: HTTP Cookie Lifetime: ( 00:10:00 ) o resto ficarão como esta.

Para ficar mais completo, ainda pelo Winbox configure seu SNMP.
Clique na aba ( IP + SNMP )
Marque o Enabled e em:
Campo Contact Info: ( coloque seu e-mail )
Campo Location: ( brazil )
Clique em ok e pronto.

Agora irei repassar as regras para funcionar.

OBS: Use o terminal mikrotik para adiciona-las...

MASCARA INTERNET

Código: Selecionar todos
/ip firewall nat add action=masquerade chain=srcnat out-interface=Internet

REDIRECIONANDO PARA O PROXY

Código: Selecionar todos
/ip firewall nat add action=dst-nat chain=dstnat comment="REDIRECT PROXY" disabled=no dst-address-list=!sem_proxy dst-port=80 protocol=tcp src-address-list=proxy\ to-addresses=192.168.0.1 to-ports=3129

ABRILITAR REDES PARA USO JUNTO COM O PROXY
Código: Selecionar todos
/ip firewall address-list add address=5.0.0.0/20 comment="CLIENTES" disabled=no list=proxy
/ip firewall address-list add address=192.168.0.1 comment="PROXY" disabled=no list=sem_proxy


ABRILITAR PARA USO DO CACHE A FULL NA MESMA INTERFACE DA INTERNET

Código: Selecionar todos
/ip firewall mangle
add action=mark-connection chain=postrouting comment="PROXY" content="X-Cache: HIT from Proxy " disabled=no \ new-connection-mark=Proxy-connection passthrough=yes protocol=tcp \ src-address=192.168.0.1
add action=mark-packet chain=postrouting comment="" connection-mark=\ Proxy-connection disabled=no new-packet-mark=Proxy-packs passthrough=\ yes
add action=mark-connection chain=postrouting comment="PROXY" disabled=no dscp=12 new-connection-mark=\ proxy-hits passthrough=yes protocol=tcp src-address=192.168.0.1
add action=mark-packet chain=postrouting comment="" connection-mark=\ proxy-hits disabled=no new-packet-mark=proxy-squid passthrough=yes


ABILITAR QUEUS PARA USO JUNTO COM REGRAS CRIADAS POR VOCÊ PARA AS RESPECTIVAS VELOCIDADES DOS CLIENTES

Código: Selecionar todos
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \ max-limit=2M name="Proxy" packet-mark=proxy-squid parent=\ global-out priority=4 queue=default

lucas76
Iniciante
Iniciante

Mensagens : 4
Pontos : 1148
Reputação : 0
Data de inscrição : 16/05/2014

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum